AnsPress 4.0.0-beta.3 is out

13.98K viewsWordPress

Hello Everyone,

Please download and try our latest beta release from here:

Changelog can be seen here:

  • Normalize addons path
  • Added subscribe button
  • Check if user can access post before sending email
  • Fixed: PHP Fatal error: Uncaught Error: Call to undefined function ap_delete_subscriptions
  • Fixed: Question border not being highlighted
  • Removing codeception tests as PHPUnit test will be written from scratch
  • Improved email notification and subscribers
  • Added email queues and content table
  • Added subscription CRUD
  • Fix Categories can’t remove icon or add a new one
  • When using BuddyPress Add in the links to answers and reps don’t work.
  • Fixed MySql datatype of qameta views and flags to store large numbers
  • Fixed: illegal string offset date
  • Fixed attachment delete
  • Fixed delete uploads
  • Renamed author page to user page
  • Update term ids
  • Improved list layout
  • Include missing template files
  • Rename base.php and content-list.php to question-list.php and question-list-item.php
  • Fixed: non-logged in user seeing moderate answer
  • Removed dynamic avatar addon
  • Migrate category meta
  • Fixed static method warning
  • Fixed best answer migrate bug
  • Do not show upgrade message to new installs

Please give our project a star on GitHub. Thanks

Answered question

Please let us know what Caching Plugins are supported, if any.

Also how we can enable and test, because until now i failed totally.

Thanks !

edited comment on answer

I don’t really understand why the “caching” has always been such a mystery to Anspress.

Is that so difficult to know if and what caching is supported in Anspress 4 ? And how to activate and test ? What caching plugin and mode is supported and what not.


Thanks for your hard work!!

To me it does´t work:

  • Fix Categories can’t remove icon or add a new one
  • When on a question, any link give me a 403 error.
  • Filter on categories page

I used the tools of the plugin to completely delete all DB, and then install this new 4.0b3.

Not sure if I am doing something wrong.

commented on answer

Hello Carlos,
Is there any error in browser console?

For “When on a question, any link give me a 403 error” make sure base page exists and published.

the base page is published… the whole site is working, and with the rest of anspress too.. it is only when I enter in one question.
Could it be that the permalink structure for anspress is not working well? I changed it.

/wp-content/plugins/anspress-4.0.0-beta.3/assets/js/min/question.min.js?ver=4.0.0-beta.3 403 (Forbidden)
Gives me this error in the browser console, when I am in a question



” allow user to create private question and answer ” still can’t work in beta 3.

When I post my answer with the option “only visble to admin and moderator” ,my answer still post public. I shound change it to private manualy by cilck”…”

Sorry,I’m not good at English.

I bought almost all of the Q&A plugin for wp(CM、SABA,DW),but I had deleted them all .Beacuse I’m really like your design for your plugin. Clean and beautiful!

Thank you very much !

commented on answer

This seems to be a bug with beta version. I will push a fix.

Sorry, I can’t post any question use this version, it just loading… loading… loading…..,


Now when I am in a question, I can not write an answer, click in more options, or add a comment.

Not sure what I am doing wrong.


Hi Rahul, Hi everybody,

Here are some issues encountered while upgrading my to the new version:

  1. CSS not called in the pages anymore
  2. ‘Aaiyaa! Something went wrong. Please click above button again or report issue to us.’ while upgrading data after upgrading the plugin (apparently at the start of the reputation upgrade)… reclick on upgrade made it work for reputation but it got stucked on categories

Further to issue 1, I tried to switch to

a. Askbug parent theme : the css is called but not of the functionalities are not working (See here: )

b. Twenty-Sixteen: Everything seems fine (except that I lost the customization, and the use of the askbug licence )

I hope you ll be up to help.
Many thanks in advance,

edited comment on answer

Are you using AskBug?


@rahul nice job, where can  i found the user panel ?


Notice: Undefined property: stdClass::$ancestors in /var/www/html/wp-includes/nav-menu-template.php on line 458

Warning: in_array() expects parameter 2 to be array, null given in /var/www/html/wp-includes/nav-menu-template.php on line 458

Error at page Q&A in buddypress

commented on answer

OK, i changed slug qa to q-a! The problem is solved.
and if i set slug is ‘qa’ that still bugs!

  1. When my website’s user are click on ask question button, they redirects to home page.
  2. On wp-dashboard your “option” didn’t  show anything.
Answered question