Profile page + Reputation page lead to Nothing Found/404

5.50K viewsIssues
0

Hi,
Even though I have all necessary pages, whenever I click on someone’s profile I am redirected to a Nothing Found page. It might have to do with the fact that by default the permalinks become author/the-name-of-the-author instead of users/the-name-of-the-user. Any thoughts?
If I try to access someone’s reputation page instead I am sent to a 404 error page, see screenshot

What can be wrong?

Answered question

Have you tried saving the permalinks?

Hey,
Yes I saved them, I even changed them to see if this does not fix the problem, but when I changed them even the users page started showing 404 so I guess it did not work out. 🙁

I hope you did not forgot to create users page and set that page in AnsPress options? Please confirm

Hey, no I have users page, it works correctly – it stops working only in some cases where I change the permalinks. I will post my pages in a separate comment

0

You have not enabled the user profile addon in AnsPress. I enabled it.

Posted new comment

Wow, super easy! Thank you so much for the great support Rahul. The theme is really good so is the plugin, no regrets I bought it so far.

Thanks

0


As you can see the Users page is here, and it works – I got no problems with it. The profile page does not work, which leads me to believe that it is the reason why whenever I click on someone’s profile I see an error instead of the actual profile. I have the anspress shortcode inside, I even tried installing the plugin on a fresh WordPress to try, but it still shows the same error, so it’s not a misconfiguration on my end. Any thoughts? Thank you

Posted new comment

Can you give me access to your site?