Cloudflare’s Email Obfuscation feature will break Post Answer animation if the answer contains a mention

2.40K viewsIssues
0

Not an issue. I just want to share that Cloudflare > Scrape Shield > Email Obfuscation (enabled by default in Cloudflare) will interfere with a Post Answer animation when the answer contains a mention (e.g. @awijasa). Note that BuddyPress is also installed in my case.

Cloudflare Email Obfuscation often set an email address to [email protected] even in an AJAX call.

Thanks,

@awijasa

Hello, I am also using cloudflare but did not faced this issue. I will try and let you know.

More details about my Cloudlfare setup: It’s provided via a third-party: Siteground. Cloudflare Railgun was also enabled in addition to Scrape Shield > Email Obfuscation. To resolve this issue, I just simply turn off Email Obfuscation since I don’t really need that Clouflare feature.

I forgot to mention that BuddyPress must be installed to make the Cloudflare Email Obfuscation issue appear when Posting an answer. Edited the question to make it clear.

Thanks for detail. I have added this issue to my task list. CF is used by most site so this cannot be ignored.

0

Hello Rahul,

I want to pass along a potential cause of this Email Obfuscation problem from a colleague who has tested CloudFlare Email Obfuscation extensively:

CloudFlare only obfuscates emails when the content being returned from the server has a MIME type of text/html or application/xhtml+xml. When an email address is being obfuscated in an AJAX call it is typically because the correct content-type is not being sent by the server.

Since this happened on an answer with a mention, this problem may have something to do with the BuddyPress plugin.

Thanks,

Adrian

commented on answer

Thanks for sharing your findings.
AnsPress ajax response is always HTML. I will check what I can do to fix this issue.