Shortcode for questions doesn’t work

3.00K viewsIssuesquestion shortcode

Im working with Anspress and Elementor. I created a “question template” with Elementor Theme Builder, and now im trying to use the shortcode question, but doesn’t works.
I tried:

[question id=XXX]
[question id="XXX"]

Also I tried other shortcodes like:

[anspress post_parent="XXX"]

All the time the results are in blank. If I see the code only prints:

<div id="anspress" class="ap-eq"></div>

Im doing something wrong?

Unselected an answer

This has been fixed. And new version will release shortly.

Edited comment


I see now [question] shortcode is working… but not properlly 🙁

I have an Elementor template for the Anspress Questions, and i need to show the question by using a shortcode widget from Elementor. Im doing that by using a dynamic ID, so the shortcode result is something like [question id=993]

Doing this, the question is showing, but WITHOUT the answers and WITHOUT the textbox to write a new answer.

Instead of this, the question is showing with a “See all answers” button, that is not working.

I need to show the question with all answers visible and with the textbox to write a new answer visible too.

Thanks 🙂

PD: I tried to use [anspress post_parent="XXX"] shortcode, but seems to work in Elementor editor screen but not in the frontend (result is in blank)


Something new with this?

Unselected an answer

Thanks for reporting. This seems to be a bug. I have created an issue and will be fixed shortly.

Posted new comment

Ok thank you Rahul 😉