Re-counting doesn’t work

7.67K viewsIssues
0

I have tried 5 re-count options and they’re stopping to work after first 50 posts. All the same.

View post on imgur.com

It just stucks like that.

Hello,
I did not tested counter with that huge numbers of posts but counter can handle any numbers of posts. Do you see any error in log while running re-count?

0

Open anspress-question-answer/admin/views/recount.php

Find line around 192

if(currentRequest > 5) change it to if(currentRequest > 5000)

And the recounting worked successfully all of the sudden :)
commented on answer

While it help to keep the ajax calls alive, it did not fix my issues. Reputations still at the same level as before.

Thanks for suggestion. I will check it.

0

This issue is still continue for v4.1.0 too. Only reputation re-counting can go to 300.

0

I don’t understand this one is related to anspress or not, but when I tried again, i got these in my logs.

[11-May-2017 15:54:55 UTC] PHP Notice: Undefined property: stdClass::$ancestors in /home/…/public_html/…/wp-includes/nav-menu-template.php on line 458

[11-May-2017 15:54:55 UTC] PHP Warning: in_array() expects parameter 2 to be array, null given in /home/…/public_html/…/wp-includes/nav-menu-template.php on line 458

commented on answer

Thanks for info. But this is not related to AnsPress. I will test re-count in site having a huge numbers of questions and update you all.