Question comments not appearing, and no email being sent

Solved5.58K viewsWordPress

Hi. Updated from v4 from Master GIT branch, but comments still do not appear, and no mail is being sent. Deleted old mail addon from v3, no difference. Comments do not appear despite complete removal of plugin and reinstallation.

Any help much appreciated. Example can be seen in this link


selected answer

Hmm – seems like the notification works for new questions (emails being sent), so ignore that part 🙂 However, comments still do not show 🙁

Yes, its not loading for me either. Did you tried posting new comments?

Yes. If you look at the questions, there’s a test question I posted after the upgrade. There is a comment here, and that doesn’t show either. Very odd.

Any thoughts please ? Slightly confused by this one. I originally thought it had to do with MMR (Merge Minify Refresh) so disabled that.

No change. Then disabled the caching plugin. No change. Pressing F12 in chrome to reveal the developers console shows no errors, so it’s almost like the comments aren’t being called ?

I don’t see any issue on AnsPress. Please send me credentials for further testing on your site.

Done. Sent in private message

Its look like something wrong with JS code. I will check in-depth this evening.

Thanks Rahul. Much appreciated. Let me know if I can help in any way.

This seems to be a bug, working on fixing it.

Any update ? Thanks


RESOLVED – You wouldn’t believe it. V3 of the plugin creates a root directory of anspress-question-answer. When I reinstated v3, everything started to work again (but obviously with the previous version). I looked at the root folder I was using for v4, and it was called anspress-master. I renamed this to anspress-question-answer, and everything started working !

commented on answer

Thanks for update.

Another oddity here. On my PC, it works fine, but not on a mobile device… Strange,

I believe this has to do something with minify JS. If you have not installed any caching plugin then it may be done by your host. Please confirm.


Here is what i see in your site:


commented on answer

Thanks. MMR disabled, but still no comments showing

All plugins disabled, and theme set to default WordPress. No comments showing. Going to check Apache logs now to see if they yield anything

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

Thanks, but I’m not using that WordPress theme – it’s the 2017 default. Additionally, Same Origin Policy wouldn’t stop the comments loading I think…

Just saying that there are errors. Several. And since we can’t replicate it, it must be something related to your setup. Sorry i have no more ideas.

Hello Cagliostro,
This was solved. Very interesting solution though.


Any update on this please ? I’ve stripped my WordPress installation back to nothing – no plugins, default theme – still doesn’t show any comments ! Even fired up a new raw instance with nothing on it, and the comments still do not show !

commented on answer

I can’t replicate it also.

Most probably it is some conflict in your installation. What is “MMR” folder in your WP (oc-content) ? I see some script errors in browser debugger….

Is that Merge/Minify/Refresh ? plugin ? If so, it shows errors.

Thanks for the response. Yes, that’s Merge / Minify / Refresh. I even disabled that plugin and have deleted the MMR folder, but it doesn’t seem to make any difference. Where are you seeing the errors ?

I see errors in browser debug window in each Question page.

I run two Anspress sites and i see no error in comments.

Thanks. I don’t see anything when I press F12 to bring up the developer console ?


Just received an email telling me there’s a new comment, but don’t see it. Email notification works great, but no comments displayed.