URLs break when using Polylang.

646 viewsWordPress
0

1. Create a new question through the admin panel with administrator rights. And a question with the wrong url is created – https://edieta.org/ru/questions/question/kak-udalit-akkaunt-v-instagram/.
With the indication of the locale of the main language. Although Polylang has disabled the display of the main locale. All other plugins see this.
2. I also noticed that url does not appear on the edit page. /// usually shows the future url immediately.
3. There is a slash at the end, although in constant links I have an url without a slash at the end. In my case, the correct url looks like this – https://edieta.org/questions/question/kak-udalit-akkaunt-v-instagram
The “Permalinks” section of your plugin settings does not work. Doesn’t work properly.
Whom am I writing to? None of the developers come here. 🙂

Answered question
0

AnsPress does not work well with language code hidden. We will release a fix for that in up coming days.

Posted new comment

I temporarily solved this problem for the main language using the plugin – Permalink Manager Lite . But this is a bad solution and only for the main language, the problem is not solved for the second language. The second language redirects to the main one.
I hope you fix it. I saw in the code that you are trying to take urls from polylang.

You are viewing 1 out of 1 answers, click here to view all answers.