PHP Notice: map_meta_cap – AnsPress 2.7

7.16K viewsUpdates
1

PHP Notice:  map_meta_cap was called <strong>incorrectly</strong>. The post type answer is not registered, so it may not be reliable to check the capability “edit_post” against a post of that type. Please see <a href=”https://codex.wordpress.org/Debugging_in_WordPress”>Debugging in WordPress</a> for more information. (This message was added in version 4.4.0.) in /home/wp-includes/functions.php on line 3792

 

 

PHP Notice:  map_meta_cap was called <strong>incorrectly</strong>. The post type answer is not registered, so it may not be reliable to check the capability “read_post” against a post of that type. Please see <a href=”https://codex.wordpress.org/Debugging_in_WordPress”>Debugging in WordPress</a> for more information. (This message was added in version 4.4.0.) in /home/wp-includes/functions.php on line 3792

1

Ok, found the cause and fixed it. Not sure why there were some stray comments belonging to anspress questions that have been deleted or missplaced the comments during an update … i dunno.

Deleting those two comments, fixed the problem.

-1

Rahul this is an old Question but please help.

I get this error EVEN with Anspress disabled. How that can be ?

[23-Mar-2017 11:03:51 UTC] PHP Notice:  map_meta_cap was called <strong>incorrectly</strong>. The post type answer is not registered, so it may not be reliable to check the capability “read_post” against a post of that type. Please see <a href=”https://codex.wordpress.org/Debugging_in_WordPress”>Debugging in WordPress</a> for more information. (This message was added in version 4.4.0.) in /home/wp-includes/functions.php on line 4137

[23-Mar-2017 11:03:51 UTC] PHP Notice:  map_meta_cap was called <strong>incorrectly</strong>. The post type answer is not registered, so it may not be reliable to check the capability “edit_post” against a post of that type. Please see <a href=”https://codex.wordpress.org/Debugging_in_WordPress”>Debugging in WordPress</a> for more information. (This message was added in version 4.4.0.) in /home/wp-includes/functions.php on line 4137
[2

 

 

Is that a leftover maybe from old Anspress versions ? How can i solve this notice ?

Thanks

commented on answer

Hello Cagliostro, I dont think its AP. AP dont have a function named map_meta_cap. All function of AnsPress are prefixed with ap_. Please try to find the source file of issue.

The problem is not map_meta_cap but the “The post type answer is not registered”. That type is yours, isn’t it ?