Get a 404 Error when I try to Ask a Question

11.64K viewsCoreAnspress
1

I uploaded the “Anspress.master.Zip” file ( https://github.com/open-wp/anspress/archive/master.zip) since the “PR8 version” from wordpress.org gave me a fatal error upon activation.<br/><br/>
When i go to the main page it says, “No question asked yet!, be the first to ask a question.”<br/><br/>
When I click the “Ask Question” button it takes me to a 404 Error page.

0

Your answer must have 5 words or more.

0

Hello,

I’ve found an bug in anspress when you’re setting anspress as a static page and you’ve installed it in document root i’ll be redirect to homepage and when i try to ask question too but when i don’t set as default page and then go to /anspress it’ll work without problems and there’s bug with years it always says 45 years ago i’m happy if you can fix the issues rahul.

Kind Regards

0

Just sent login details to your email.
Thank you.

0

Still having same issue.
Can you please login to the Admin area and see what issue is and resolve ?

0

OK.
Thank you for the reply.
Will you email us a download link please?
– OR –
will it be updated on wordpress.org  ?

0

Hello, Yes I have fixed it. I will push it after 1-2 hour. Cause also pushing some lots of fixes with it.

0

Hello Rahul,
Just following up to see how things are going.

0

Thank you for your help.
Look forward to the solution.
 

0

Please do not worry I am working on this bug and I will release a fix tomorrow.

0

I’ve found the issue in case i had the same problem you have to set nothing as static page and it’ll work in separete page.