edit answer error

Solved7.11K viewsIssuesedit answer
0

i cant edit submitted answer. already tried using 2 account. a participant or an administrator, still error.

 

Question is closed for new answers.
selected answer

Attachments

error-1.png
1

update:

I tried at two different sub domain it still failed to edit submitted answer. all anspress plugin are updated to 4.1.6 version.

 

and as i mention above, i tried to edit my answer here, and it works.

 

i find a different permalink structure.

when i edit answer on my site here the permalink:

http://chart.paktua.id/edit/?id=159&__nonce=538c184b8b

when i edit answer here:

https://anspress.io/questions/edit/?id=28223&__nonce=f590614a99

 

and i tried manually add ‘questions’ on my permalink, still error not found.

i also disabled all other plugin. still error not found.

selected as best answer

Make sure you have not set base page as WordPress front page. Save permalinks.

finally, this is the answer: make sure DO NOT set base page as WordPress front page.

after chose another page as front page, everything works fine.

thank you very much rahul, you’re the best!

0

hi rahul

thanks for the update, the problem about ”answer that  appear in wrong place” is solved

but the first error that i report about i cant edit submitted answer is still persistence

maybe it is a permalink error? below is my permalink setting

i can make a credential for you to my website if you want.

thank you

update: 

hi rahul,

I did the update to 4.1.6, and the error still persist

NO Problem with editing the question
the problem is the submitted answer, i cant edit it.

anyway, tried to edit answer here, seems no problem.

commented on answer

Please get version 4.1.6 and save your permalink and then try. Lemme know if problem persists.

hi rahul,

I did the update to 4.1.6, and the error still persist

NO Problem with edit the question
but i cant edit the submitted answer.

Send access to your site at [email protected]

1

hi rahul

happy new year 2018,

i just update to 4.1.5 version, but the problem is still there.

and i found new problem,

so after i update the plugin, i wrote a reply to question on my website, when i tried to edit, the error is still there

and

the answer that i submit appear in all other submited question, yes, somehow it appear in wrong place. even in question with 0 answer, when i open it, the question that i submited after update to 4.1.5 is there.

please check it on my website.

the submited answer after update is at this link : http://chart.paktua.id/Discussion/148-kren-yang-taat-pada-teknikal-analisis/

thank you.

commented on answer

Hello Arif,
Thank you and same to you.
A new version is on its way. 4.1.6 will release in 2-3 hours.

0

In 4.1.5, I’m sure users can edit the answer, however the following error is occurring when users try to edit the answer. Rahul, do you have any idea to fix this?

 

Warning: Creating default object from empty value in /***/wp-content/plugins/anspress-question-answer/lib/class-form.php on line 521

edited answer
0

Hello,

Issue was already resolved in 4.1.5. Kindly get latest from GitHub https://github.com/anspress/anspress/archive/master.zip. 4.1.5 is not yet published in wp.org but safe to use.

0

I have the same problem