commenting doesn’t work

3.51K viewsIssues
0

Hi,  We are using anspress and commenting is enabled in the backend, however, when you click comment to leave a comment, a JS popup never occurs and the page just scrolls down to the answer input form.  Is there something that I am doing wrong to enable commenting?

 

Our q/a page is quadquestions.com/qa

 

Commenting doesn’t work on any questions or answers, on any browser, logged in or not.

http://4.stefantsov.com/s/?2016.01.04_5.59.40_gxh39dzx.png
There is not even a button to press to leave a comment, logged in or not.

Are you sure user have proper permission?

You are right Dima, However, when a registered user is logged in, the option to leave a comment is available. I updated the permissions so that all users can see the comments, but this doesn’t change anything, unregistered users still cannot see or leave comments, and registered users can see the link to leave a comment, but it doesn’t work, it just takes you to the answer input form.

Please send team viewer details.

“However, when a registered user is logged in, the option to leave a comment is available.”
That’s what I’m saying. I have registered and I had NO OPTION TO LEAVE A COMMENT.

Rahul guess was probably right, you might have not set “default user role: anspress participants”.
You have contacted support now and it’s probably fixed already. Would be useful to know what the issue was.

we are still working on it. It appears that a user that leaves a comment is logged out and marked as anonymous. I am trying to disable plugins to find the culprit. Ill post here when we fix it.

@Dima, actually problem is that when user visit question page they get logged out..

Hi Rahul, Do you think that this could have to do with an SSL or Htaccess issue?

Have you figured out what the problem was? We have just the same issue on our site – when you click comment to leave a comment, a JS popup never occurs and the page just scrolls down to the answer input form. But on my localhost the same site with the same plugins works just right.