AnsPress 4.1.8 is READY for release!!!

6.48K viewsUpdatesrelease
2

Hello Everyone,

AnsPress 4.1.8 is ready for release. Please give it a try on on your development site and let us know your feedback. It can be downloaded from GitHub [zip].

This time it took more time to release AnsPress. I wasn’t able to work due to my personal problems. Thanks for your understanding.

This version will be published to wp.org on 17th April, if no critical bug discovered by that time.

Thanks you, happy coding.

Question is closed for new answers.
Marked as closed

Kuddos Rahul!
Gonna try it on my staging site. 😀

Thanks Fred.

0

[Bug Reporting]
If I make a question with some category, there is the question which I have make when I search other category in question list page.
But! If I change my browser ( Chrome -> Safari ), There is no the question when I search other category.

Is this a session problem?

Posted new comment

If you posted without logging in and question status is “moderate” or “private” then yes you’ll not be able to see it in other browser. Its because of AnsPress session.

Thank you for your reply,

Here is a scenario.

1. Login as a default user
2. Ask a question with some category( like… computer science )
3. search questions by category( like, music )
4. there is the question which I ask right before in very first position!
5. I checked the query string
– SELECT ….. OR ( wp_posts.post_author = 1
AND wp_posts.post_status IN (‘publish’, ‘private_post’, ‘trash’, ‘moderate’)
) )
OR ( wp_posts.ID IN (1402)

1402 -> the question in computer science category

6. open safari and enter my site
7. of course, there is the question which I asked right before.
8. search by category ( music ) again
9. of course, the question in computer science is not shown.

Is this a default session setting? or did I something wrong?

Check please!

Please create a new question for this issue. I will check your issue.

0

Thank you for plugin.
i think new update to v.4.1.8 disables site if either Tags for Anspress or Categories for Anspress are active.
Could be just my site (network/multisite) local.
error log at this link

Posted new comment

Please remove all old AnsPress addons:
tags-for-anspress
categories-for-anspress
anspress-email

0

i use last version from github. i don’t know why, but users can’t edit their answers.
I think it happens after was fixed a bug with editing questions.

Posted new comment

@Rahul Aryan if you need, i can give you admin and user account on my website to demonstrate the error

Just tried it on demo and localhost and working as expected.

can i restore anspress setting to default?

Yes you can. add this code to functions.php and remove it again once you have refreshed the page.

delete_option( ‘anspress_opt’ );
delete_option( ‘anspress_reputation_events’ );
delete_option( ‘anspress_addons’ );

0

in lib/form/class-editor.php

$settings = array(
      'textarea_rows' => 10,
      'tinymce' => array(
        'content_css' => ap_get_theme_url( 'css/editor.css' ),
        'wp_autoresize_on' => true,
        'statusbar' => false,
        'codesample' => true,
        'anspress' => true,
        'toolbar1' => 'bold,italic,underline,strikethrough,bullist,numlist,link,unlink,blockquote,fullscreen,apmedia,apcode',
        'toolbar2' => '',
        'toolbar3' => '',
        'toolbar4' => '',
      ),
      'quicktags' => false,
      'media_buttons' => false,
      'textarea_name' => $this->field_name,
    );
 $editor_args = wp_parse_args( $this->get( 'editor_args' ), $settings );


I think it is not good to settle the ‘toolbar1’ buttons because other Editor Plugin not works. Your settings override other plugins button setting.
How about just use ‘mce_buttons’ hook?
wp-editor will merge your setting with other settings.
Now I’m using like this

function alp_remove_anspress_editor_buttons( $editor_args ) {
 unset($editor_args['tinymce']['toolbar1']);
 return $editor_args;
}
add_filter( 'ap_pre_editor_settings', 'alp_remove_anspress_editor_buttons' );
 function alp_add_anspress_default_editor_buttons( $buttons ) {
 $anspress_defualt_buttons = array( 
  'bold', 'italic', 'underline', 'strikethrough', 'bullist', 'numlist', 'link', 'unlink', 'blockquote', 'fullscreen', 'apmedia', 'apcode' );
 array_merge( $buttons, $anspress_defualt_buttons );
 return $buttons;
}
add_filter( 'mce_buttons', 'alp_add_anspress_default_editor_buttons', 1000, 1 );


Check this please.

Posted new comment

Hello,
That is is being done intentionally. This helps output controlled buttons to public users but if you want more buttons in tinymce you can override option using our hook.

0

Sorry, the recount still does not work for me:
http://prntscr.com/j69pkw
Alex

Edited answer
0

HI Rahul,

There are two really similar Translation fields, please check:

http://prntscr.com/j68w6g
http://prntscr.com/j68wbw

From my understand, they are actually same,  should they be one?

Alex

Posted new comment

Hello, Nothing is wrong in there.

0

Hi Rahul,
there are still errors with TaskBreaker:
http://prntscr.com/j68oc4
or please access this page for check:https://forum.lovcour.com/project/
this issue will cause “update task” does not work:
http://prntscr.com/j68phl

Alex

Posted new comment

Alex, please consult with its author, not an AnsPress issue.

0

Reply comment does not work both on your official site and my site:
http://prntscr.com/j68mar
http://prntscr.com/j68mr8

Posted new comment

Yes, that’s a bug. This will be fixed.

1

Recount for answer is working now, thanks.
but the count of comment does not work properly, please check the screenshot:
it will show 0 even if there is comment:http://prntscr.com/j68l93

Alex

Answered question
0

Hi Rahul,
I disabled Reputation Add-on, but everytime I reactivated Anspress, the Reputation addon will be automatically activated.

Alex

Posted new comment

Hello Alex,
Yes, reputation and email addons are always enabled by default on activation.