Anonymous/ non logged in users are still not able to answer questions

Solved6.85K viewsIssues
0

Dear Raul,

Please check – https://experts.ng

Non logged in users are still not able to answer questions. This is very critical to my platform as most users will not register now until the platform gains traffic.

What can I do, I’ve been waiting for way too long to solve this single problem.

Thanks

Question is closed for new answers.
selected answer

Please note that I am using the very new updated release

Its because you have not changed option:
Who can post answer?
to
Only logged in

0

Hello,

Please make sure to check user access control options. There you can control who can post or not.

commented on answer

i can give you access to my backend

I mean you have to change options. Go to wp-admin->AnsPress->Options->User Access Control.
And then change posting permission to logged in only.

To logged in only??

I am talking about allowing anonymous users to post answers, not logged in users.
I tried sending you a private message, don’t know if you saw that. Please this is a very significant issue for me; a major deal breaker. Please help look into this.

i already sent my backend details, and can resend it if you don’t have it

I’ve done this Rahul but still not working.

Ok… I see that the problem was with my child theme. I guess a file from my child contains the very old files version that did not include the update.

I guess I may never stop using the developer that worked on the site afterall, regardless of the child theme. As long as there is an update, I just may need to call him back 🙁

Please share link to your old file, may be I will be able to help a little.

old file? Should I send you the admin panel or the ftp/cpanel link?

Once I activate my child theme, then nothing works, and once the child main upgrade is activated, I lose the custom changes I made. So its a major issue for me.

I’ll appreciate your help, but how do I send you my link to enable you check?

I think you are in my skype contact, ping me there.