404 Error when viewing any question

5.00K viewsCore
0

Thanks a lot for the impressive plugin! Really awesome!

 

I can view all the questions through this link: http://staging.xxxxx.com/questions/

However, I am getting a 404 when I try to view any of these questions: http://staging.xxxxx.com/questions/question/new-question/

 

I am setting Permalink to /%postname%/

and AnsPress options are:

Base page slug before question permalink [checked]

Base page: ANSPRESS_TITLE

and the ANSPRESS_TITLE page aka Questions has this shortcode [anspress]

 

How can this issue be solved. I really want to get it working!

 

All the best,

Asmaa

Asmaa, send me site details with temproary login to [email protected]. I will have a look

Its look like you have lots of Q&A plugin installed, disable all first. all conflicting with each other. after disabling them update anspress option once.

I deactivated the plugins, but it is still giving me the 404 error. What do you mean by updating the anspress option? I went to the options page and saved it again, but still the same error 404

1

Go to AnsPress option and enable base page slug before question:

Thank you for your speedy response! It is already enabled\checked. What else can I do?

Check if base page is set as home page, if yes unset from home page.

The base page is set to ANSPRESS_TITLE which has the shortcode [anspress]

Excuse me @Asmaa_Ayman, did you redirect base page to another page (for seo)? in this case you lost your Anspress subpages.

No @morteza, I did not.